$re = '/^(([\d]{9}[13579]\d [a-z]+ski)|([\d]{9}[02468]\d [a-z]+ska))$/';
$str = '96112103648 kowalska
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);