re = /^(([\d]{9}[13579]\d [a-z]+ski)|([\d]{9}[02468]\d [a-z]+ska))$/
str = '96112103648 kowalska
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end