import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{8})\\s*(\\d{10})\\s*([\\d/]+)\\s*([\\d\\.]+)\\s*([\\d\\.]+)\\s*([\\d\\.]+)";
final String string = "\n"
+ " \n"
+ "We have effected a fund transfer to a/c No 00070110000017 with HDFC BANK for Rs\n"
+ "19,44,671.20(Rupees Ninteen Lakh Forty Four Thousand Six Hundred Seventy One and Paise\n"
+ "Twenty Only) against the below mentioned payment Details.\n"
+ "________________________________________________________________________________ \n"
+ "Invoice Number Document Number Document date Invoice Amount \n"
+ "Deductions Net Amount \n"
+ "________________________________________________________________________________ \n"
+ " 108027883 5001211394 28/12/2020 486167.80 \n"
+ " 0.00 486167.80 \n"
+ " 108027884 5001211396 28/12/2020 486167.80 \n"
+ " 0.00 486167.80 \n"
+ " 108027886 5001211401 28/12/2020 486167.80 \n"
+ " 0.00 486167.80 \n"
+ " 108027885 5001211408 28/12/2020 486167.80 \n"
+ " 0.00 486167.80 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}