use strict;
my $str = '
We have effected a fund transfer to a/c No 00070110000017 with HDFC BANK for Rs
19,44,671.20(Rupees Ninteen Lakh Forty Four Thousand Six Hundred Seventy One and Paise
Twenty Only) against the below mentioned payment Details.
________________________________________________________________________________
Invoice Number Document Number Document date Invoice Amount
Deductions Net Amount
________________________________________________________________________________
108027883 5001211394 28/12/2020 486167.80
0.00 486167.80
108027884 5001211396 28/12/2020 486167.80
0.00 486167.80
108027886 5001211401 28/12/2020 486167.80
0.00 486167.80
108027885 5001211408 28/12/2020 486167.80
0.00 486167.80 ';
my $regex = qr/(\d{8})\s*(\d{10})\s*([\d/]+)\s*([\d\.]+)\s*([\d\.]+)\s*([\d\.]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}