package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\*\*Header2\*\*.*[\n\r]
(?P<content>[\s\S]+?)
(?=^\*\*)`)
var str = `**Header1**
thing1
thing2
thing3
thing4
**Header2**
dsfgs
sdgsg
empty line
rrrrrr
**Hello Dolly**
abider
abcder
ffffff
etc.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}