re = /^\*\*Header2\*\*.*[\n\r]
(?P<content>[\s\S]+?)
(?=^\*\*)/mx
str = '**Header1**
thing1
thing2
thing3
thing4
**Header2**
dsfgs
sdgsg
empty line
rrrrrr
**Hello Dolly**
abider
abcder
ffffff
etc.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end