$re = '/(\d+) (\w+)(?: \+| -|$)/';
$str = '12 CO2 + 6 H2O -> 2 C6H12O6 + 12 O2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);