import re
regex = re.compile(r"(\d+) (\w+)(?: \+| -|$)")
test_str = "12 CO2 + 6 H2O -> 2 C6H12O6 + 12 O2"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")