using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<name>\b\w+\b)\s*=\s*(?<value>""[^""]*""|'[^']*'+)";
string input = @"id='1019' name='Beer' color='#e7c705'";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}