// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?<name>\b\w+\b)\s*=\s*(?<value>"[^"]*"|'[^']*'+)"#).unwrap();
let string = "id='1019' name='Beer' color='#e7c705'";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}