$re = '/(?<name>\b\w+\b)\s*=\s*(?<value>"[^"]*"|\'[^\']*\'+)/';
$str = 'id=\'1019\' name=\'Beer\' color=\'#e7c705\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);