using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=\S{5,100}$)(?!\S*\d{9})[A-Za-z0-9][A-Za-z0-9$\\._-]*@[A-Za-z0-9$\\._-]+\.[A-Za-z0-9]+$";
string input = @"test@test.com
test@test.co.uk
test123456789@test.com
test@test
$test@test.com
test@test@test.com
test@test().com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}