$re = '/^(?=\S{5,100}$)(?!\S*\d{9})[A-Za-z0-9][A-Za-z0-9$\\\\._-]*@[A-Za-z0-9$\\\\._-]+\.[A-Za-z0-9]+$/m';
$str = 'test@test.com
test@test.co.uk
test123456789@test.com
test@test
$test@test.com
test@test@test.com
test@test().com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);