import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=\\S{5,100}$)(?!\\S*\\d{9})[A-Za-z0-9][A-Za-z0-9$\\\\._-]*@[A-Za-z0-9$\\\\._-]+\\.[A-Za-z0-9]+$";
final String string = "test@test.com\n"
+ "test@test.co.uk\n\n"
+ "test123456789@test.com\n"
+ "test@test\n"
+ "$test@test.com\n"
+ "test@test@test.com\n"
+ "test@test().com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}