import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "flaschen";
final String string = "flaschen\n"
+ "flaschenzug\n"
+ "zugflaschen\n"
+ "flaschen-zug\n"
+ "zug-flaschen\n"
+ "flaschenpfand\n"
+ "flaschen pfand\n"
+ "pfandflaschen\n"
+ "pfand flaschen\n"
+ "mehrwegflaschenpfand";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}