$re = '/flaschen/m';
$str = 'flaschen
flaschenzug
zugflaschen
flaschen-zug
zug-flaschen
flaschenpfand
flaschen pfand
pfandflaschen
pfand flaschen
mehrwegflaschenpfand';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);