// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)flaschen").unwrap();
let string = "flaschen
flaschenzug
zugflaschen
flaschen-zug
zug-flaschen
flaschenpfand
flaschen pfand
pfandflaschen
pfand flaschen
mehrwegflaschenpfand";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}