re = /flaschen/m
str = 'flaschen
flaschenzug
zugflaschen
flaschen-zug
zug-flaschen
flaschenpfand
flaschen pfand
pfandflaschen
pfand flaschen
mehrwegflaschenpfand'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end