const regex = /^[A-Za-z].*\R\K[0-9](?=\R0$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[A-Za-z].*\\R\\K[0-9](?=\\R0$)', 'gm')
const str = `ABC
5
0
gdfgdfg
-----------
GHN
0
ffffffff
fffff
ffff
trte
-------------
H
1
0
----------------`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);