$re = '/^[A-Za-z].*\R\K[0-9](?=\R0$)/m';
$str = 'ABC
5
0
gdfgdfg
-----------
GHN
0
ffffffff
fffff
ffff
trte
-------------
H
1
0
----------------';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;