# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A-Za-z].*\R\K[0-9](?=\R0$)"
test_str = ("ABC\n"
"5\n"
"0\n"
"gdfgdfg\n"
"-----------\n"
"GHN\n"
"0\n"
"ffffffff\n"
"fffff\n"
"ffff\n"
"trte\n"
"-------------\n"
"H\n"
"1\n"
"0\n"
"----------------")
subst = "\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.