using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"src='.*?(?=')'";
string input = @"src=''
src='pass001'
src='https://google.com'
src=""failed001'
src='failed002""
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}