re = /src='.*?(?=')'/
str = 'src=\'\'
src=\'pass001\'
src=\'https://google.com\'
src="failed001\'
src=\'failed002"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end