const regex = /src='.*?(?=')'/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('src=\'.*?(?=\')\'', 'g')
const str = `src=''
src='pass001'
src='https://google.com'
src="failed001'
src='failed002"
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}