$re = '/src=\'.*?(?=\')\'/';
$str = 'src=\'\'
src=\'pass001\'
src=\'https://google.com\'
src="failed001\'
src=\'failed002"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);