import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([0-2]\\d|30)/(0[4-9]|1[012])|(31/(0[578]|10|12)))/1999";
final String string = "01/03/1999 too early\n"
+ "30/03/1999 too early\n"
+ "01/04/1999\n"
+ "31/04/1999 invalid date (month-specific)\n"
+ "35/04/1999 invalid date\n"
+ "30/05/1999\n"
+ "31/05/1999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}