import re
regex = re.compile(r"(([0-2]\d|30)/(0[4-9]|1[012])|(31/(0[578]|10|12)))/1999", flags=re.MULTILINE)
test_str = ("01/03/1999 too early\n"
"30/03/1999 too early\n"
"01/04/1999\n"
"31/04/1999 invalid date (month-specific)\n"
"35/04/1999 invalid date\n"
"30/05/1999\n"
"31/05/1999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")