const regex = new RegExp('(([0-2]\\d|30)/(0[4-9]|1[012])|(31/(0[578]|10|12)))/1999', 'gm')
const str = `01/03/1999 too early
30/03/1999 too early
01/04/1999
31/04/1999 invalid date (month-specific)
35/04/1999 invalid date
30/05/1999
31/05/1999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}