#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(?:Sun|Mon|Tue|Wed|Thu|Fri|Sat),)?\s*([0-9]{2})(?:\s+|-)([Jj][Aa][Nn]|[Ff][Ee][Bb]|[Mm][Aa][Rr]|[Aa][Pp][Rr]|[Mm][Aa][Yy]|[Jj][Uu][Nn]|[Jj][Uu][Ll]|[Aa][Uu][Gg]|[Ss][Ee][Pp]|[Oo][Cc][Tt]|[Nn][Oo][Vv]|[Dd][Ee][Cc])(?:\s+|-)([0-9][0-9]([0-9][0-9])?)\s+(?:([01][0-9]|[2][0-3])):([0-5][0-9]):([0-5][0-9])\s*(?:GMT)?"
Local $sString = "Wed, 23-May-12 01:23:31 GMT " & @CRLF & _
"23-May-12 01:23:31 GMT " & @CRLF & _
"23-May-12 01:23:31 " & @CRLF & _
"23 May 2012 01:23:31 GMT " & @CRLF & _
"23 May 2012 01:23:31 GMT" & @CRLF & _
"Wed, 23 May 2012 01:23:31 GMT" & @CRLF & _
"23 mAy 2012 01:23:31 GMT" & @CRLF & _
"23 maY 12 01:23:31" & @CRLF & _
"23 jan 12 22:23:31" & @CRLF & _
"01 AUG 12 15:23:31 GMT" & @CRLF & _
"" & @CRLF & _
"01 bla 12 15:23:31 GMT" & @CRLF & _
"1 May 2012 15:23:31 GMT" & @CRLF & _
"01 May 2012 15:23:31 BLA" & @CRLF & _
"01 May 2012-15:23:31" & @CRLF & _
"01 May 2012-15/23:31" & @CRLF & _
"01 May 2012-15/23:31"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")