use strict;
my $str = 'Wed, 23-May-12 01:23:31 GMT
23-May-12 01:23:31 GMT
23-May-12 01:23:31
23 May 2012 01:23:31 GMT
23 May 2012 01:23:31 GMT
Wed, 23 May 2012 01:23:31 GMT
23 mAy 2012 01:23:31 GMT
23 maY 12 01:23:31
23 jan 12 22:23:31
01 AUG 12 15:23:31 GMT
01 bla 12 15:23:31 GMT
1 May 2012 15:23:31 GMT
01 May 2012 15:23:31 BLA
01 May 2012-15:23:31
01 May 2012-15/23:31
01 May 2012-15/23:31';
my $regex = qr/(?:(?:Sun|Mon|Tue|Wed|Thu|Fri|Sat),)?\s*([0-9]{2})(?:\s+|-)([Jj][Aa][Nn]|[Ff][Ee][Bb]|[Mm][Aa][Rr]|[Aa][Pp][Rr]|[Mm][Aa][Yy]|[Jj][Uu][Nn]|[Jj][Uu][Ll]|[Aa][Uu][Gg]|[Ss][Ee][Pp]|[Oo][Cc][Tt]|[Nn][Oo][Vv]|[Dd][Ee][Cc])(?:\s+|-)([0-9][0-9]([0-9][0-9])?)\s+(?:([01][0-9]|[2][0-3])):([0-5][0-9]):([0-5][0-9])\s*(?:GMT)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}