import re
regex = re.compile(r"(?:(?:Sun|Mon|Tue|Wed|Thu|Fri|Sat),)?\s*([0-9]{2})(?:\s+|-)([Jj][Aa][Nn]|[Ff][Ee][Bb]|[Mm][Aa][Rr]|[Aa][Pp][Rr]|[Mm][Aa][Yy]|[Jj][Uu][Nn]|[Jj][Uu][Ll]|[Aa][Uu][Gg]|[Ss][Ee][Pp]|[Oo][Cc][Tt]|[Nn][Oo][Vv]|[Dd][Ee][Cc])(?:\s+|-)([0-9][0-9]([0-9][0-9])?)\s+(?:([01][0-9]|[2][0-3])):([0-5][0-9]):([0-5][0-9])\s*(?:GMT)?")
test_str = ("Wed, 23-May-12 01:23:31 GMT \n"
"23-May-12 01:23:31 GMT \n"
"23-May-12 01:23:31 \n"
"23 May 2012 01:23:31 GMT \n"
"23 May 2012 01:23:31 GMT\n"
"Wed, 23 May 2012 01:23:31 GMT\n"
"23 mAy 2012 01:23:31 GMT\n"
"23 maY 12 01:23:31\n"
"23 jan 12 22:23:31\n"
"01 AUG 12 15:23:31 GMT\n\n"
"01 bla 12 15:23:31 GMT\n"
"1 May 2012 15:23:31 GMT\n"
"01 May 2012 15:23:31 BLA\n"
"01 May 2012-15:23:31\n"
"01 May 2012-15/23:31\n"
"01 May 2012-15/23:31")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")