const regex = /(?:(?:Sun|Mon|Tue|Wed|Thu|Fri|Sat),)?\s*([0-9]{2})(?:\s+|-)([Jj][Aa][Nn]|[Ff][Ee][Bb]|[Mm][Aa][Rr]|[Aa][Pp][Rr]|[Mm][Aa][Yy]|[Jj][Uu][Nn]|[Jj][Uu][Ll]|[Aa][Uu][Gg]|[Ss][Ee][Pp]|[Oo][Cc][Tt]|[Nn][Oo][Vv]|[Dd][Ee][Cc])(?:\s+|-)([0-9][0-9]([0-9][0-9])?)\s+(?:([01][0-9]|[2][0-3])):([0-5][0-9]):([0-5][0-9])\s*(?:GMT)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?:Sun|Mon|Tue|Wed|Thu|Fri|Sat),)?\\s*([0-9]{2})(?:\\s+|-)([Jj][Aa][Nn]|[Ff][Ee][Bb]|[Mm][Aa][Rr]|[Aa][Pp][Rr]|[Mm][Aa][Yy]|[Jj][Uu][Nn]|[Jj][Uu][Ll]|[Aa][Uu][Gg]|[Ss][Ee][Pp]|[Oo][Cc][Tt]|[Nn][Oo][Vv]|[Dd][Ee][Cc])(?:\\s+|-)([0-9][0-9]([0-9][0-9])?)\\s+(?:([01][0-9]|[2][0-3])):([0-5][0-9]):([0-5][0-9])\\s*(?:GMT)?', 'g')
const str = `Wed, 23-May-12 01:23:31 GMT
23-May-12 01:23:31 GMT
23-May-12 01:23:31
23 May 2012 01:23:31 GMT
23 May 2012 01:23:31 GMT
Wed, 23 May 2012 01:23:31 GMT
23 mAy 2012 01:23:31 GMT
23 maY 12 01:23:31
23 jan 12 22:23:31
01 AUG 12 15:23:31 GMT
01 bla 12 15:23:31 GMT
1 May 2012 15:23:31 GMT
01 May 2012 15:23:31 BLA
01 May 2012-15:23:31
01 May 2012-15/23:31
01 May 2012-15/23:31`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}