#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?:\.?\/?.+\/)?(?:app(?:[0-9A-F]+)?|(?:jquery|angular|three)(?:\-?\d[\-\.]\d[\-\.]\d)?)(?:\.min)?\.js$"
Local $sString = "jquery.min.js" & @CRLF & _
"app.min.js" & @CRLF & _
"app.js" & @CRLF & _
"app4eefa86.min.js" & @CRLF & _
"jquery-3.2.1.js" & @CRLF & _
"jquery-3-2-1.min.js" & @CRLF & _
"/js/app.min.js" & @CRLF & _
"./scripts/jquery.js" & @CRLF & _
"/cgi-bin/angular.min.js" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")