using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\.?\/?.+\/)?(?:app(?:[0-9A-F]+)?|(?:jquery|angular|three)(?:\-?\d[\-\.]\d[\-\.]\d)?)(?:\.min)?\.js$";
string input = @"jquery.min.js
app.min.js
app.js
app4eefa86.min.js
jquery-3.2.1.js
jquery-3-2-1.min.js
/js/app.min.js
./scripts/jquery.js
/cgi-bin/angular.min.js
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}