import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\.?\\/?.+\\/)?(?:app(?:[0-9A-F]+)?|(?:jquery|angular|three)(?:\\-?\\d[\\-\\.]\\d[\\-\\.]\\d)?)(?:\\.min)?\\.js$";
final String string = "jquery.min.js\n"
+ "app.min.js\n"
+ "app.js\n"
+ "app4eefa86.min.js\n"
+ "jquery-3.2.1.js\n"
+ "jquery-3-2-1.min.js\n"
+ "/js/app.min.js\n"
+ "./scripts/jquery.js\n"
+ "/cgi-bin/angular.min.js\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}