$re = '/(?:\.?\/?.+\/)?(?:app(?:[0-9A-F]+)?|(?:jquery|angular|three)(?:\-?\d[\-\.]\d[\-\.]\d)?)(?:\.min)?\.js$/im';
$str = 'jquery.min.js
app.min.js
app.js
app4eefa86.min.js
jquery-3.2.1.js
jquery-3-2-1.min.js
/js/app.min.js
./scripts/jquery.js
/cgi-bin/angular.min.js
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);