package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"[^"]*"(?::(*SKIP)(*F))|"([^"]*)"`)
var str = `{"nextDeliveryDays":["i dag torsdag 20. april","mandag 24. april","onsdag 26. april","fredag 28. april","onsdag 3. mai"],"isStreetAddressReq":false}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}