import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"[^\"]*\"(?::(*SKIP)(*F))|\"([^\"]*)\"";
final String string = "{\"nextDeliveryDays\":[\"i dag torsdag 20. april\",\"mandag 24. april\",\"onsdag 26. april\",\"fredag 28. april\",\"onsdag 3. mai\"],\"isStreetAddressReq\":false}\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}