$re = '/"[^"]*"(?::(*SKIP)(*F))|"([^"]*)"/m';
$str = '{"nextDeliveryDays":["i dag torsdag 20. april","mandag 24. april","onsdag 26. april","fredag 28. april","onsdag 3. mai"],"isStreetAddressReq":false}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);