re = /"[^"]*"(?::(*SKIP)(*F))|"([^"]*)"/m
str = '{"nextDeliveryDays":["i dag torsdag 20. april","mandag 24. april","onsdag 26. april","fredag 28. april","onsdag 3. mai"],"isStreetAddressReq":false}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end