import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<log_time>[0-9-]+ [:0-9,]+)\\s+-\\s+(?<severity>\\w+)\\s+-\\s+(?<message>.*)$";
final String string = "2022-07-20 15:21:31,994 - INFO - Moving to Dashboard";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}