re = /^(?<log_time>[0-9-]+ [:0-9,]+)\s+-\s+(?<severity>\w+)\s+-\s+(?<message>.*)$/m
str = '2022-07-20 15:21:31,994 - INFO - Moving to Dashboard'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end