const regex = /^(?<log_time>[0-9-]+ [:0-9,]+)\s+-\s+(?<severity>\w+)\s+-\s+(?<message>.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<log_time>[0-9-]+ [:0-9,]+)\\s+-\\s+(?<severity>\\w+)\\s+-\\s+(?<message>.*)$', 'gm')
const str = `2022-07-20 15:21:31,994 - INFO - Moving to Dashboard`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}