#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!zzz)(?=\S{2,5000}$).*(.{3}//.{0,100})(?!\w)"
Local $sString = "ssdfsdfsdfasdfasdfasdfdfd//yH5BAEkjfsdafdfsafasdfas" & @CRLF & _
"zzzsdf//yH5BAEkjfsdafdfsafasdfas" & @CRLF & _
"ssdfsdfsdfasdfasdfasdfdfd//yH5B"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")