import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!zzz)(?=\\S{2,5000}$).*(.{3}//.{0,100})(?!\\w)";
final String string = "ssdfsdfsdfasdfasdfasdfdfd//yH5BAEkjfsdafdfsafasdfas\n"
+ "zzzsdf//yH5BAEkjfsdafdfsafasdfas\n"
+ "ssdfsdfsdfasdfasdfasdfdfd//yH5B";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}