const regex = new RegExp('^(?!zzz)(?=\\S{2,5000}$).*(.{3}//.{0,100})(?!\\w)', 'gm')
const str = `ssdfsdfsdfasdfasdfasdfdfd//yH5BAEkjfsdafdfsafasdfas
zzzsdf//yH5BAEkjfsdafdfsafasdfas
ssdfsdfsdfasdfasdfasdfdfd//yH5B`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}