import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https:\\/\\/)?(esika.tiendabelcorp.com)\\/(mx|pe)\\/([a-zA-Z0-9@:%._+~\\/#?&=-]{2,256})";
final String string = "https://esika.tiendabelcorp.com/pe/maquillaje/c/esika-01\n"
+ "https://esika.tiendabelcorp.com/pe/delineador-de-ojos-punta-plumon-eye-pro/p/200108655\n"
+ "https://esika.tiendabelcorp.com/pe/set-red-power/p/200112223\n"
+ "https://esika.tiendabelcorp.com/pe\n"
+ "https://esika.tiendabelcorp.com/pe/delineador-de-ojos-punta-plumon-eye-pro/p/200108655";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}