$re = '/(https:\/\/)?(esika.tiendabelcorp.com)\/(mx|pe)\/([a-zA-Z0-9@:%._+~\/#?&=-]{2,256})/m';
$str = 'https://esika.tiendabelcorp.com/pe/maquillaje/c/esika-01
https://esika.tiendabelcorp.com/pe/delineador-de-ojos-punta-plumon-eye-pro/p/200108655
https://esika.tiendabelcorp.com/pe/set-red-power/p/200112223
https://esika.tiendabelcorp.com/pe
https://esika.tiendabelcorp.com/pe/delineador-de-ojos-punta-plumon-eye-pro/p/200108655';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);