import re
regex = re.compile(r"(https:\/\/)?(esika.tiendabelcorp.com)\/(mx|pe)\/([a-zA-Z0-9@:%._+~\/#?&=-]{2,256})", flags=re.MULTILINE)
test_str = ("https://esika.tiendabelcorp.com/pe/maquillaje/c/esika-01\n"
"https://esika.tiendabelcorp.com/pe/delineador-de-ojos-punta-plumon-eye-pro/p/200108655\n"
"https://esika.tiendabelcorp.com/pe/set-red-power/p/200112223\n"
"https://esika.tiendabelcorp.com/pe\n"
"https://esika.tiendabelcorp.com/pe/delineador-de-ojos-punta-plumon-eye-pro/p/200108655")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")