// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(https:\/\/)?(esika.tiendabelcorp.com)\/(mx|pe)\/([a-zA-Z0-9@:%._+~\/#?&=-]{2,256})").unwrap();
let string = "https://esika.tiendabelcorp.com/pe/maquillaje/c/esika-01
https://esika.tiendabelcorp.com/pe/delineador-de-ojos-punta-plumon-eye-pro/p/200108655
https://esika.tiendabelcorp.com/pe/set-red-power/p/200112223
https://esika.tiendabelcorp.com/pe
https://esika.tiendabelcorp.com/pe/delineador-de-ojos-punta-plumon-eye-pro/p/200108655";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}